Page 1 of 1

Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:26pm
by Zeemax_Mini
Well driving along yesterday suddenly the oil pressure light came on...not a good sign! So I pulled over straight away and sure enough it had dumped all its oil. I left it overnight thinking the worst, but went back this morning and the oil filter had come completely lose and lost the oil through there. So I did it up and re-filled with oil, then restarted the engine. Started normally, oil pressure light went off....then I heard a pop and it had popped the oil filter off and dropped the oil again! I bought a new oil filter and this time it didnt pop off, have driven it about 50 miles home and it didnt come of or anything in that time. But the threads on the old one dont look stripped, and as its a brand new engine the filter has only been on for about 100 miles! What could have caused it to pop off!? Thanks, Dom

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:33pm
by theminiofv
hmmm

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:36pm
by RikWalsh
what was the o-ring seal like on the old filter?.. did it drop off completely? :-k ive seen similar before, but not on a mini.

Rik

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:44pm
by Zeemax_Mini
The o-ring looked fine! When I heard the pop it hadnt completely come off, just become really loose! Dom

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:46pm
by retro_10s
sounds strange... could it be something to do with the little spring loaded ball that sits on the bit you screw the filter to?

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:50pm
by Zeemax_Mini
Hmm i havent noticed a spring loaded ball but Ill have a look! The weird thing is is that the old filter doesnt even look like it has a stripped thread, yet it definitely popped off and the new one didnt! Dom

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 06:56pm
by retro_10s
are the threads on the filter housing stripped?.... the ball sits in the housing, you'll have to look under the car and up into the filter housing to see it.... so it could be messy. I think it's the filter bypass, basically if the filter gets clogged then the pressure pushes the ball up and allows oil circulation...... as unfiltered oil is stil better than no oil.

it' just unlikely it's seized though as it sits in oil!!!! grrrrr, I'm really not sure.

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 07:04pm
by Zeemax_Mini
The threads on the filter housing look fine actually...but the weird thing is that the ones on the oil filter dont look too bad either! If it 'popped' off rather than unscrewed...something must be stripped! If you see what im saying....if u can pull a nut off a bolt...it must be stripped! But it just doesnt look like it! Dom

RE: Oil Filter Popped Off - Too High Pressure?

PostPosted: Tue 13th Jun 2006, 10:59pm
by keithyboy
If it was excess oil pressure it would be throwing it out of the breathers. I have heard of cars bursting the filter cannister to the oil pressure relief valve sticking (though I've never seen one) but I've never heard of one coming loose like that.

Had the can ballooned up at all?

PostPosted: Tue 13th Jun 2006, 11:49pm
by Zeemax_Mini
Nope! Can didnt look damaged in any way! Ive put a new one one and am carrying a spare new one in the car, so guess Ill just hope it was a dodgy one! Dom

PostPosted: Wed 14th Jun 2006, 08:42am
by GraemeC
Might be a badly formed thread - afterall these things aren't a cut thread and are churned out by the million, if the machine had an off day it may be on the edge of production tolerences.
Was it 100% definately the correct filter?

PostPosted: Wed 14th Jun 2006, 10:53am
by Zeemax_Mini
Yeh fairly sure it was the right filter. Ill just have to hope it was a dodgy one I guess! Dom

PostPosted: Wed 14th Jun 2006, 11:00am
by ceejam
Unipart GFE 166 or 443

Or Rover filter?

If not, it ain't the correct filter IMO!

PostPosted: Wed 14th Jun 2006, 12:36pm
by Zeemax_Mini
Umm it was a champion one which popped off, the only one the shop had (Which is on it now) is by KFE or something....but i have 2 spares of Unipart which will be the next ones to go on in a few miles when I do an oil change. Dom